Power Window problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 21-06-02 Thread Starter
Status: Q
AO Member
Kenneth's Avatar
Join Date: Mar 2001
Location: Malaysia
County: -
Posts: 49

Member car:

156 2.5 Q-system

Power Window problems

Weird problem with my driver's side power window. It goes down ok. However, coming up is the problem. Pressing the 'Up' button, I hear 2 very quick 'clicks' from the relay under the dashboard but the window stays down.

Now here is the even more annoying part. If the window is partially down and I press the 'Up' button, it goes down a little and then stops. Repeating the 'Up' button press does the same thing until it could go down no more. Then you have to patiently try the 'Up' button a few times like say 40 before the window behaves normally and goes up!

Anyone knows where the control board of the power window is for automatic operation on driver's side?

Kenneth is offline  
Sponsored Links
Status: - Update
Posts: n/a
If this power window systems uses a relay, then maybe it could the the problem. What do you other guys think?
Status: Fixing all your keys !!
AO Silver Member
Chris's Avatar
Join Date: Mar 2001
Location: United Kingdom
County: Tyne and Wear
Posts: 3,806
Images: 2

Member car:

a very dirty car

The relay is at least easy to check...

When you say that the window works normally again, is it slower that the other window, or has it been getting slower in the past?

This would indicate that either the mechanism is sticking but more likely that the motor is starting to fail.
Chris is offline  
Status: - Update
Posts: n/a

I had exactly the same problem. You can forgot a relay problem ! In fact you must hear a click in the door when pressing the button.
I removed the motor,and found a component inside wich cut electricity when hot. I tried to bypass it but then the fuse broke (and funny thing it was the climate control fuse who broke - All Alfa have strange electric scheme...)
In fact, your motor is dead, you have to change it... Sorry.


1996 155 1.7 TS
1983 Gtv6
1980 Gtv 2.0
1991 75 1.6 IE

Status: -
AO Silver Member
richward's Avatar
Join Date: Feb 2001
Location: Wombourne, UK
Posts: 1,134

Member car:

156 2.0 Veloce

My drivers side window has problems during wet weather - something must be getting damp somewhere... but I'm guessing it's related to the thermal cutout. Leave it for a few seconds and it moves a bit more, a few more seconds a bit more...
richward is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

power , problems , window

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome