Bad earth as well? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Bad earth as well?

Reading about Antonios electrical probelems, got me thinking about one of my friends' 1998 2l 16v.

Only sometimes his speedo and odo meters don't work, but on the next trip, it works again.
When he puts the aircon on, these instruments never work.
Can it also be bad earts? Where shall we look?

Sponsored Links
Status: Fixing all your keys !!
AO Silver Member
Chris's Avatar
Join Date: Mar 2001
Location: United Kingdom
County: Tyne and Wear
Posts: 3,806
Images: 2

Member car:

a very dirty car

I cant personally advise you where to look for a bad earth in your case, but often if you think an earth may be bad it is as easy to just make a new one. Find where the earth connects to the instrument cluster and run a black or brown wire from there to a convenient earth point - make one if you have to or reuse any one you fine that looks easy to get to. It saves some time trying to hunt down the real bad earth and in fact will also circumvent any other bad earths down the line.
Mr Bodge-it strikes again!
Chris is offline  
Mark T
Status: - Update
Posts: n/a
Hi Guys,
I had a similar problem with the instruments on a Lancia Dedra a couple of years ago. When it had rained, or snowed or been damp (usual UK crappy weather), the instrument panel used to go haywire; wrong and erratic gauge readings etc. Thought at first this was the voltage regulator, however it just turned out,(after 2 months of weekend tinkering), to be a bad earth in the footwell. Guess the 155 has similar electrical gremlins, however I must say that so far (touch wood), everthings been fine on my V6.


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

bad , earth

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome