The heater!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
The heater!!

HI everybody!!
Anybody have trouble with their heater controls - the heat not quite shutting off properly, and the air direction control not quite directing properly! (My car does NOT have the automatic climate control).

HELP please

Sponsored Links
Status: Fixing all your keys !!
AO Silver Member
Chris's Avatar
Join Date: Mar 2001
Location: United Kingdom
County: Tyne and Wear
Posts: 3,806
Images: 2

Member car:

a very dirty car

Never managed to fix it though.
Chris is offline  
Status: - Update
Posts: n/a
have same problem - to get air onto screen dial is in totally wrong position.
had same problem on previous fiat tipo (same heater controls) - replaced plastic cogs on back of dials with scrapyard parts as they were stripped- also cables had stretched over the years causing less than full movement at flaps/water valves.
haven't summoned up enthusiasm or courage to start dismantling dash on 155 but bet problem is the same.
my output (especially volume of air) has always been crap on this car.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome