weird sound from exhaust.. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
weird sound from exhaust..

when i reach 2500-3500 rpm. in my 2.0 ts 16v.
it start to make some rattle or something..
It sound like a lose heat shield, but they ain't loose. it drives me crazy..aarg
Sponsored Links
Status: - Update
Posts: n/a

A similar noise on mine was due to some baffles inside the silencer being loose. It was especially noticable on lift-off from high revs as the gas pressure dropped.

A good excuse for a nice custom stainless one?

Status: - Update
Posts: n/a
Could be the dreaded catalyst?

Mine went once, and it too drove me crazy for ages! If i was you i'd get that checked,
mine was completely shot, and the insides had broken up completely causing the rattle.


Status: -
AO Member
Join Date: Jan 2001
Location: Sheffield, South Yorkshir
Posts: 715
I had this on my 1997 155. There is a little heat sheild spot welded in 4 places to the downpipe just before the cat. Two of these welds broke and I tied the rest on with stainless steel wire. Then the other two welds broke and I took the whole lot off and have had no side effects.

The other thing it could be is the plastic under tray for the engine if your car has one. This often drops down and catches on things.
Henry Yorke is offline  
Status: - Update
Posts: n/a
I had the same thing as henry, except i ripped it off straight away... no side affect seen.

Status: - Update
Posts: n/a
I also have that noise. My exhaust is brand new, removed cat, don't have that thing on the down pipes, and also not plastic undertray.
What about that small box just after the lambda sensor? Couldn't that be it. Although tapping mine with the hand doesn't make any noises. Maybe I am not hitting hard enough....Anybody know what that is by the way? If it is a pre-cat, is it also restrictive, or not?

Good luck

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

exhaust , sound , weird

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome