Ignition Leads - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Ignition Leads

Has anyone ever replaced a set of ignition leads on a later model 97-on. I'm wanting to replace mine but can't seem to find out where they are connected (not the coil side) as they are wrapped in tape.

Any advice or past experience would be appreciated.

Thanks in advance
Sponsored Links
Status: -
AO Silver Member
richward's Avatar
Join Date: Feb 2001
Location: Wombourne, UK
Posts: 1,134

Member car:

156 2.0 Veloce

On a '97 on model, there aren't really any ignition leads - not of the HT type anyway. There are low voltage trigger wires probably the ones in the tape that you mentioned, which trigger the four individual coils (one for each cylinder) under the alu head cover. If my memory serves me correctly (I replaced the cover as soon as I looked under there - too complicated!) each coil sits on top of the rubber insulation and connection for the main plug for that cylinder, plus a short HT lead to the secondary plug for the next-but-one cylinder. So for the main plug there's no lead to break down, but the coil may fail, and if the secondary lead fails, (the 'twinspark' bit) it won't really make that much difference. If your coils are failing, prepare yourself for a bill a bit bigger than the 10 for a normal set of HT leads!

There's always one - and it's usually me!
richward is offline  
Status: - Update
Posts: n/a
Thanks for that Richward, I suppose the leads that can be changed are from the coil to the secondary spark plug. Someone mentioned a while back that the leads could be sparking to the alloy cover which made the car feel irregular, these must be them.

Mike Scarf
Status: - Update
Posts: n/a

I've change 2 of the 4 leads between the coils. They cost about 16 each from the Alfa dealers. By the way one was a short one and one was long, but they were about the same price. By the way if my memory serves me correctly 2 of the coils are on the main plugs and 2 are on the secondary plugs .

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

ignition , leads

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome