wiper problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 18-06-11 Thread Starter
Status: -
Join Date: Feb 2010
Location: United Kingdom
County: Glasgow
Posts: 8
Help wiper problems

hi guys http://www.alfaowner.com/Forum/image...ies/thumbs.gif

my alfa 155 has a wiper problem ?
its seems that no matter how far down i set my wipers they keep hitn
my driver door ! so once again i ask all you pros for your help

cheers scott
bigtommo is offline  
Sponsored Links
Status: -
AO Member
b0shty's Avatar
Join Date: May 2011
Location: United Kingdom
County: Aberdeen
Posts: 63

Member car:


b0shty is offline  
Status: -
AO Member
s4vge's Avatar
Join Date: May 2011
Location: Ireland
County: Clare
Posts: 60

Member car:

White 2.0ltr 155

mine always used to hit the passenger door but never drivers'... cant remember for sure but could you not take the wiper arm off the motor sprocket and move it a couple of notches then it should only go to a certain point. cant remember exactly what i used to do but i know it was something along these lines
s4vge is offline  
Status: Its a fixer upper
AO Member
Join Date: Jan 2010
Location: United Kingdom
County: Aberdeenshire
Posts: 294
Undo the bolt holing it on & move it up 2 or 3 notches. Not much else you can do except get a shorter arm.
unquestioned is offline  
Status: turbo powwa
AO Silver Member
celadon's Avatar
Join Date: Nov 2005
Location: United Kingdom
County: Kent
Posts: 5,423
Images: 9
The problem is caused by wear in the linkage due to age.
You could put a shorter blade on, but then you would not be clearing the screen too well.

You could try shortening the linkage somehow.
celadon is offline  
Status: Giggity Giggity...... Giggitygoo
AO Silver Member
Alfa155 TS's Avatar
Join Date: May 2009
Location: Ireland
County: Dublin
Posts: 3,230
Images: 7

Member car:

75 2.0 8v

I had the exact same problem and I discovered at some point a previous owner replaced the armsbut fitted the wrong ones and like you mine where hitting the drivers door. As soon as I replaced them with originals the problem went away. If you have the right arms however adjusting them is easy
Alfa155 TS is offline  
Status: -
AO Platinum Member
Ralf S.'s Avatar
Join Date: Feb 2002
Location: The land that Time forgot
Posts: 12,568
Images: 18
Make sure you have the right length arms

Make sure your blades are the correct length

See if you can re-position the arms on the spline so that the wipers park lower on the windscreen

If none of this works you probably have worn linkages. Replace the linkages or fit 1" shorter blades.. though as has been written you will be clearing a bit less of the windscreen.

Ralf S.
Ralf S. is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

problems , wiper

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome