Newbie. Alfa 155 ts won't start - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 03-01-11 Thread Starter
Status: -
AO Member
Join Date: Jan 2011
Location: United Kingdom
County: East Sussex
Posts: 10

Member car:

Alfa 155

Boxing Newbie. Alfa 155 ts won't start

Hi all. Had my car standing for a few weeks now it won't start. Having a mare with it really. Not had it long. Drove it fine no probs now turns over won't fire. Code light stays on now bonnet cable's a 2.0 ts

Probably gonna sell it anyway .think it's a wide body model in red. Lowered adj susp, bodykit etc.

Any clues on how to get bonnet up etc

Wayne t is offline  
Sponsored Links
Status: age is only a number ;-)
AO Gold Member
rgwm's Avatar
Join Date: Aug 2004
Posts: 9,069
The non-start will most likely be down to corrosion on the contact of the relays in front of the battery, or bad connections on the wires going into the relay blocks - not uncommon.

But of course first you have to get the bonnet open....IIRC you can just about manage to reach the bonnet release catches from underneath with a long screwdriver or some such - it may help to get someone to press down on the bonnet as you try to operate the catches to take the pressure off the catch.
rgwm is offline  
Status: Two Alfas now in the house!
AO Member
Sebasteeno's Avatar
Join Date: Jun 2006
Location: United Kingdom
County: East Riding of Yorkshire
Posts: 207
Images: 26
After very little use recently my 155 had died so i stuck some jump leads on from my other car and tried starting my 155 but the code light was on and it wouldnt fire. I was told to disconnect the battery for half an hour then reconnect and leave it charging for a bit. I did this and my 155 started immediately.
Sebasteeno is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

155 , alfa , newbie , start

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome