HELP! 155 Twin Spark 2.0 Rev Problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 17-12-10 Thread Starter
Status: -
Join Date: Dec 2010
Location: Philippines
County: Tarlac
Posts: 1

Member car:

155 T.Spark 2.0

HELP! 155 Twin Spark 2.0 Rev Problem

Hi, my alfa is a 155 TS 2.0 with manual transmission. The engine has revving problems. It needs 10 seconds to rev from idle (900rpm) to 2000rpm but when it reaches 2000rpm, it can rev up to its redline with no hesitations. Car can be driven normally at highway speeds due to the high rpm but can be a pain in the **** in Stop and Go Traffic especially on inclines.

Already replaced spark plug, fuel pump, fuel filter . . . cleaned air filter and the 3 sensors on the intake manifiold tube.

I am from Manila Philippines, Alfa Romeo closed shop back in 1998... Local Mechanics are not familiar with my car. What can i check or replace??

Thanks in advance

Manila155 is offline  
Sponsored Links
Status: -
AO Member
chris_155v6's Avatar
Join Date: Apr 2008
Location: Argentina
County: Buenos Aires
Posts: 448
Images: 17

Member car:

Gt1600, Benz

Check the fuel pressure regulator. Do you see black smoke coming out of the exhaust during hesitation?
chris_155v6 is offline  
Status: -
AO Member
Ruby116's Avatar
Join Date: Jul 2008
Location: St Ives Cornwall
Posts: 167
I had the same kind of problem the icv valve gets coked up, remove it clean it soak it in WD40 then refit, should take 10-15 mins it sits on the throttle body to the right, hope it works

merry christmas!
Ruby116 is offline  
Status: Going Postal
AO Member
V8pete's Avatar
Join Date: Jan 2006
Location: United Kingdom
County: Leicestershire
Posts: 237
V8pete is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

155 , problem , rev , spark , twin

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome