155 2.0 TS Super 16v - Stereo Wires - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 11-11-09 Thread Starter
Status: -
Join Date: Nov 2009
Location: United Kingdom
County: Greater London
Posts: 4

Member car:

155 TS Super 16v

155 2.0 TS Super 16v - Stereo Wires

Just got my first Alfa 155 and wanted to drop in my CD Head unit as the one in there is just a phillips Tape player, There 3 plugs and my CD player only has 2 (when plugged in only the front speakers work and no amp) does anyone know what to do? I also wouldn't mind it turning of with the ignition??? http://www.alfaowner.com/Forum/image...s/confused.gif
G-love155 is offline  
Sponsored Links
Status: bought a 75 3.0
AO Silver Member
155 Lounge Winner 09
shiny_car's Avatar
Join Date: Dec 2006
Location: Australia
County: Victoria
Posts: 7,669
Images: 39

Member car:

GT . 155 . 75

can you post a clear photo of the plugs in your 155? my 8V only has 2 plugs, and they are non-ISO style. i would expect the 16V to have ISO plugs.

exactly what model headunit do you have?

the way i would connect it up would be:
*use a multimeter to confirm wires in the Alfa plugs
*use an adaptor harness if available: a version that plugs into the Alfa plugs, has all the wires in the correct positions, and plugs into your headunit
*or else match all the required wires and individually solder/heatshrink

presumably, the third Alfa plug goes to the rear speakers. so you could need to join these wires to the headunit's rear speakerwire outputs.

GT . 3.2 . Q2 . Kyalami Black - Red . Eibach . KONI . ASSO . ATP 19" . TAROX . FERODO . Mille Miglia exhaust
155 . 2.0 8V TS . Grigio Grey - Grey . H&R coilover . Enkei 17" . TAROX . GOODRIDGE . REMUS
75 . 3.0 . Alfa Red - Grey
shiny_car is offline  
Status: -
AO Member
Join Date: Apr 2007
Location: United Kingdom
County: Cheshire
Posts: 183
Every 16v I've had (and there's been a few) have had the ISO connection the 8v's generally require an adapter harness if an aftermarket stereo hasn't been fitted already.

Sounds like you have the standard stereo in there at the moment, an aftermarket head unit should just be plug and play.
ronb_65 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

155 , 16v , stereo , super , wires

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome