soft brake pedal - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 15-04-08 Thread Starter
Status: -
AO Member
Join Date: Nov 2002
Location: Dublin, Ireland
Posts: 34
soft brake pedal

on the road this morning i noticed my brake pedal incrasingly going soft under my foot. first bite is fine and the car comes to a halt but the pedal is soft and going closer to the floor each pump. The fluid resevoir seems ok with no obvious leaks and no warning lights are coming on

Jim Doyle is offline  
Sponsored Links
(Post Link) post #2 of 5 Old 15-04-08 Thread Starter
Status: -
AO Member
Join Date: Nov 2002
Location: Dublin, Ireland
Posts: 34
Re: soft brake pedal

Found the fault. when i went to look at the car at lunch time I noticed brake fluid stains in the drivers wheel arch. when i took off the wheel there was brake fluid on the pipe where it is attached to the strut. brake fluid level was down. have just replaced the wishbone on the passenger side last weekend and freed up rear seized brake. had'nt got around to this corner yet.

Jim Doyle is offline  
Status: Bring on the Giulia
AO Platinum Member
OperationAlfa's Avatar
Join Date: May 2007
Location: United Kingdom
County: Essex
Posts: 23,176
OperationAlfa is offline  
Status: Banned for not following the site rules
Join Date: Feb 2008
Location: United Kingdom
County: Wiltshire
Posts: 9,721
Images: 6
Re: soft brake pedal

If only this this car was a 156
Smaky is offline  
Status: -
AO Platinum Member
Ralf S.'s Avatar
Join Date: Feb 2002
Location: The land that Time forgot
Posts: 12,568
Images: 18
Re: soft brake pedal

Aye! The '55 is getting on a bit now and so you should check all the brale pipes. The front ones seem to be more vulnerable than the rears.

My o/s/f went corroded at the bottom of the pipe, where it fitted into the union.

My n/s/f went corroded there too.. but also where the pipe passed under the inner wing, into the wheel arch.

Also genooine part brake pipes are tricky to get hold of.. I had to use a copper one for my n/s.

Ralf S.
Ralf S. is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

brake , pedal , soft

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome