Alfa 155 2ltr - stalling - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools Search this Thread
Sian1201
Status: - Update
Guest
 
County: Cornwall
Posts: n/a
Alfa 155 2ltr - stalling

Hi all

My beloved 155 seems to have found a new fault. Today when I was in low revs she started to 'bunny hop' and the revs dropped to below 1000 before stalling. Additionally the injector light came on and then went off.

To be honest this one is new on me but I've wracked my brains and can only think of the following:

Fuel Pump
Ignition Coil
Injector
MAF

If anyone has had this on their car please advise.
 
Sponsored Links
Advertisement
 
Status: -
AO Member
 
Join Date: Apr 2016
Location: Swindon
County: England
Posts: 34
Garage

Member car:

147 3.2 GTA

I remember my dad having a similar issue when he owned his 155. Car would start fine but needed throttle to keep the revs up to prevent stalling. I believe this was a faulty MAF. Hope this helps.
Michael Woolfor is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 155

Tags
155 , 2ltr , alfa , stalling

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome