Selespeed 156 warning light - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 26-12-07 Thread Starter
Status: -
AO Member
Join Date: Jul 2006
Posts: 53
Selespeed 156 warning light

hi all

my selespeed warning light and flashes and also beeps, its got a mind of his own some times it wont do it for months and sometimes maybe evry 2 weeks or so, its been goin on for about 6 months now. have checked fliud and seems ok.

any one able to help me please.

eggie is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: Selespeed 156 warning light

Hi . It may be the pump sticking which will cause the hydraulic pressure to drop below 35bar. this will put the warning light on and a warning bleep only for the time it is below pressure.
Status: -
AO Member
Join Date: Nov 2006
Posts: 24

Member car:

Alfa 156

Re: Selespeed 156 warning light

New pump required!
Speedbird1 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , light , selespeed , warning

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome