156 lower strut brace fitting problem after suspension work - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 01-07-16 Thread Starter
Status: -
AO Member
Join Date: Sep 2015
Location: Adana
County: Turkey
Posts: 19
156 lower strut brace fitting problem after suspension work

It's a first for me; so seeking advice from those who know what they are doing with these things, instead of me.

Background: I installed front upper and lower strut braces on my Mk1.5 156 Selespeed a few months ago. Two weeks ago, it was turn for the Eibach Pro-Kits, which lowered the car 30mm from stock. While doing them, the guy from the shop found out that the front lower wishbone ball joints were almost gone and CV joints needed repair.

We installed new front lower wishbones yesterday; of course, while doing that, we removed the lower strut brace. Immediately after we removed it, we found that it was suddenly a few millimeters LONG! In other words, somehow the mounting points for the strut brace moved closer to each other. Hoping it was body flex, I thought they would move back after we take the car out of the lift; it did help a little but the bar still won't fit.

It's an OMP front lower strut brace/bar and I reckon only 2 more millimeters in distance between the mounting points would do. Afterall, we only removed it a few hours ago!

So how is this (a difference with this magnitute) possible? And any ideas? Maybe:

- I don't recall exactly but I think we may have installed the upper strut brace AFTER the lower one when we first did it. This time upper strut brace was on the car while we tried the lower one. Can that be the reason? Removing the front upper strut brace allow me to install the lower one?

- Couldn't have wheel alignment done after all these work (alignment shop computer was down). Would it have anything to do?
octinum is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , brace , fitting , lower , problem , strut , suspension , work

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome