156 mk2 1.8 TS 115k follow up on noisy servo - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 22-06-16 Thread Starter
Status: -
AO Member
Join Date: May 2015
Location: Cambridge
County: Cambridgeshire-
Posts: 18
156 mk2 1.8 TS 115k follow up on noisy servo

Hi All,
Firstly many thanks again for help on replacing alternator earlier in year. Eventually found best to go in from top i.e. remove manifold plenum all electrics etc.. Alternator not actually faulty but as was in process of replacing variator naturally including cam belt and alternator belts and so on, and seeing where alternator actually was decided to face this job while car part dismantled.

Also many thanks for help on Servo Problem also earlier in year. Cannot find thread now but basically -problem was a brief but loud shriek from servo on apply hard pressure on brake pedal, braking unaffected. -Advised to check for vacuum leaks. So re-made connection vacuum pipe to manifold checked pipe for cracks /splits and so on. -No difference. ...Seeing where Servo situated abandoned any further leak checking, and contemplated selling the car.. but did note servo was a Bosch so bit more confident over its continued functioning...
Put it in for MOT and actually sailed through with no advisories. Helpful person there said servo problem not unknown but does not usually affect braking..

Now get strange electronic warning sound on hard braking.. -Puzzled here as thought all faults are announced by warning lights or illuminated icons -no mention of audio warnings. Have checked pads and seems quite a bit of meat on them yet. But am still very new to Alfas.. Help Please..
cheiron is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

115k , 156 , follow , mk2 , noisy , servo

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome