Very poor economy and burning smell! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 19-12-07 Thread Starter
Status: -
AO Member
Join Date: Oct 2007
Location: Yorkshire
Posts: 91
Images: 1

Member car:

BMW 325d SE

Very poor economy and burning smell!

How about this...

I have an issue with fuel economy generally but recently I drove a 20 mile round trip covering sedate A roads and I averaged 22mpg in my 2.4 Diesel. When I got out of the car I smelt really bad burning from the rear offside. And when I was in 1st approaching my drive it was showing 5mpg as current consumption! I thought it might be slicking pads or something...

I reported to the dealer who'd said that they've never heard of this and to report it again as soon as it happens if at all.
obzidian is offline  
Sponsored Links
Status: -
AO Member
Join Date: May 2007
Location: United Kingdom
County: -
Posts: 378
Re: Very poor economy and burning smell!

I guess a good start if you think it is happening again, is to pull over somewhere safe, and carefully feel how hot the wheels are.
If one is particularly hotter than the others, then you may have a caliper that has stuck on, or maybe a handbrake that is not releasing.

ptcoll is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

burning , economy , poor , smell

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome