156 jtd 2.4 turbo problem - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: happy
AO Silver Member
nelly's Avatar
Join Date: Oct 2007
Location: United Kingdom
County: Cheshire
Posts: 1,219
Re: 156 jtd 2.4 turbo problem

ok will look again tomorrow thanks again for advise
nelly is offline  
Sponsored Links
(Post Link) post #27 of 28 Old 31-01-08 Thread Starter
Status: -
AO Member
Join Date: Dec 2007
Location: Ellon,Aberdeenshire,uk
Posts: 14
Re: 156 jtd 2.4 turbo problem

Hello again, I finally got back to this site to thank all inputs.
After getting service and MOT this month found a Turbo man/Garage only 4 miles from me hidden in the countryside.
Bingo! Plugged his test box in and suspected MAF.(Bezste & jasons thoughts)
Went back 2 days later to get it fitted.
Changing it was reasonably easy but he moved/knocked the elbow top of radiator and caused small leak.Have to go back and get fitted which is a push in with o-ring.
However leaving garage to go home!!!
J---s,,I thought when I bought the car it responded, but this is something else.It's instantaneous in any gear(and any revs it seems) when pressing your foot.Whoosh.Foot off.
Thanks all and happy new year.
peter hardy is offline  
Status: -
AO Member
Join Date: Feb 2008
Location: Poitou-Charentes, France
Posts: 94
Images: 2
Re: 156 jtd 2.4 turbo problem

Could this be a clue as to the weird behavior of my newly-acquired 156 2.4 jtd M-Jet? Just back from the Alps (love that ski-flap...) and noted during long mountain climbs a sudden surge in power as I hit 3000rpm, accompanied by a brief but embarrassing cloud of smoke.
The turbo is new, having been replaced for the previous owner by the official Alfa agents where I purchased the car - they told me that the problem turned out to be 'a valve', but they did the turbo anyway...
I'd appreciate any insight here, being new to all this !

rmfrance is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , jtd , problem , turbo

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome