156 heater just stopped! Help please - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 14-12-07 Thread Starter
Status: -
AO Member
Join Date: Oct 2007
Location: Rochdale(originally Nottm
Posts: 153

Member car:


156 heater just stopped! Help please

Hi there, seen that i may be joining a few others with this problem!

had my alfa 15 months and nothing gone wrong until now!
driving back from the trafford centre tonight, the fans on my 156 stopped. didnt matter whether was on a/c or normal, speed or direction, NOTHING! then a few miles later started working again.

Went and got fuel and then they stopped again.

When i sat in the car at the house with engine running and played with controls, i can hear things moving when i change direction settings but the fans wont work at any speed.

im hoping that this isnt gonna cost me a fortune! any help anyone!?

Im in rochdale and think that Fiat dealership might be the only answer as have no technical knowledge!


Last edited by chamb14; 14-12-07 at 20:15.
chamb14 is offline  
Sponsored Links
Status: Stopped
AO Member
Il Dottore's Avatar
Join Date: May 2005
Location: United Kingdom
County: Bedfordshire
Posts: 345
Re: 156 heater just stopped! Help please

Have a look at this thread. It could be the relay or resistor:

Il Dottore is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , heater , stopped

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome