Alfa 156 JTD `04 Turbo blown - Alfa Romeo Forum
You are currently unregistered, register for more features.    
  • 1 Post By JON156VELOCE
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 28-05-16 Thread Starter
Status: -
Join Date: Mar 2008
Posts: 2
Alfa 156 JTD `04 Turbo blown

Hello fellas. My turbo is gone i think. The car has no power, there is whinning grinding noise when the turbo is supposed to kick in. There is oil in the pipe to the cooler and is smoking bluish smoke. What turbo can use apart from the same car? It is 1.9 8v 115hp. I know it is gt1749v and the part should be 46786078. Anything else compatible or if anyone has one for sale please let me know. Any help is welcome.
cardinala is offline  
Sponsored Links
Status: Working Hard On 156 Veloce 3.0 Turbo Project
AO Silver Member
mirlock's Avatar
Join Date: Mar 2014
Location: United Kingdom
County: Northamptonshire
Posts: 1,240
before you renew make sure there are no splits in the intake hoses,
mirlock is offline  
Status: -
AO Silver Member
JON156VELOCE's Avatar
Join Date: Jun 2011
Location: United Kingdom
County: Cardiff
Posts: 2,026
You can get a new or refurbed unit for under 200 but before fitting it you need to find out why its failed, a blocked oil feed pipe or banjo bolt is not unheard of.
joeymannero likes this.
JON156VELOCE is online now  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , alfa , blown , jtd , turbo , `04

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome