Aerial Problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 13-12-07 Thread Starter
Status: -
Join Date: Dec 2007
Posts: 2

Member car:

Alfa Romeo 156

Aerial Problems

I have just recently bought a second hand Alfa 156, it doesnt have the factory fitted CD Player.

The CD player doesnt seem to receive FM but does receive MW and LW and the CD player works. This leads me to think that it may be the aerial connection.

Does anyone know how to access the aerial, as I understand it its in the rear windscreen or just under? How do I access it and what do I check to see if it is an aerial fault?


swagner is offline  
Sponsored Links
Status: -
AO Silver Member
marko's Avatar
Join Date: Jan 2006
Location: United Kingdom
County: Tyne and Wear
Posts: 2,736
Images: 4
Re: Aerial Problems

have you checked its connected at the back of the head unit? its possible when the aftermarket unit was fitted that the ariel was skipped...

welcome to the forums btw
marko is offline  
Status: -
AO Member
russ's Avatar
Join Date: Nov 2006
Location: United Kingdom
County: Lincolnshire
Posts: 101

Member car:

156 selespeed

Re: Aerial Problems

Hi swagner, this may be an urban myth but I thought the aerial was the rear demister wire. Is your demister worker and connected correctly. I do agree that the likely scenario is that the new head unit wasn't wired up fully.
russ is offline  
(Post Link) post #4 of 6 Old 14-12-07 Thread Starter
Status: -
Join Date: Dec 2007
Posts: 2

Member car:

Alfa Romeo 156

Re: Aerial Problems

The rear demister works fine. The radio worked when i got the car and FM reception was fine. I may have gone over a bump and dislodged the aerial slightly causing a poor signal through the aerial?

I thought if i could look at the aerial it may be simple enough to plug back in but i cant figure out how to get to it?! I have checked the back of the actual CD player and the aerial input there is fine.

Any more ideas...?
swagner is offline  
Status: -
AO Silver Member
jug's Avatar
Join Date: Jul 2007
Location: United Kingdom
County: Durham
Posts: 3,681
Images: 23
Re: Aerial Problems

you'll never find an aerial because it is the demister element on the glass. if your demister works then it is obviously connected which means your only possible problem is the connection behind the headunit or the headunit's internal tuner is faulty.
jug is offline  
Status: Tin worm attack ... ARGHH!
AO Gold Member
gazza82's Avatar
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 8,286
Images: 12
Re: Aerial Problems

Aerial uses the two thin lines at the top of the rear screen (above the demister). Behind the side panel next to the rear seat and to the rear of the o/s passenger door is the aerial amp which can sometime come adrift.

Some radios have an adaptor for the aerial connection so make sure it hasn't come adrift further down from the headunit.

But the fact you are getting a signal on the MW & LW suggests a possible problem with the headunit ... most 156 radios get FM but struggle with MW!

Some ra
gazza82 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

aerial , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome