Alfa gt wiper rubbing - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 23-05-16 Thread Starter
Status: -
Join Date: Jan 2015
County: -
Posts: 5

Member car:

Smart Roadster

Alfa gt wiper rubbing

Hi all
I have a problem with drivers side wiper arm rubbing on the bonnet edge.
Took arms and scuttle off and wiper mechanism seems fine
Had a look at the past posts on this but seems normally this is to do with a broken mechanism whoch in my case does not seem to be the problem
Any ideas welcome
aruss2000 is offline  
Sponsored Links
Status: DB9 Top Gear Track
AO Silver Member
pubsinger's Avatar
Join Date: Jan 2007
Location: United Kingdom
County: East Sussex
Posts: 1,629
Go on typos1, tell him his wiper's fitted incorrectly.

It's a known problem, the wipers weren't designed for a RHD car. I solved this by clenching and bending the linkage ever so slightly so that, when fitted, the arm clears the bonnet.

Good luck

pubsinger is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

alfa , rubbing , wiper

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome