Oil leak please help. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 22-05-16 Thread Starter
Status: -
AO Member
Join Date: Sep 2015
County: -
Posts: 118
Oil leak please help.

My 156 1.6 ts has developed a leak this week.
The car only has 60k and its the first bit of trouble it has given me of the 10k ive done in it so far.
I forst noticed it when I got a strong oil burning smell after coming off the motorway. On inspection there was oil everywhere underneat.
The oil was dripping from somewhere and onto the exhaust. First place to check was the variator solinoid and inlet gasket, which I only replaced 2 months ago after fitting 2.0 cams. No leaks there so I degreased and power hosed underneat to try pinpoint the leak.
I left the car to idle for 15 mins and got one drip but I couldnt find it. After a short drive I checked again and there was some oil sitting on the oil/water heat exchanger. After some more driving today there is now more oil but this time from the oil pump down to the heat exchanger. There is also some oil under the oil pump running onto the side of the sump.
It does not appear to be coming from the crank though. It appears to be slightly forward of the crank, but I could be wrong.
Is the oil pump known to leak? Is it a big fix?
Any help will be truely appreciated as Id like to get this fixed soon as.
156Harry is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Apr 2008
Location: New Zealand
County: -
Posts: 2,239
Easy things first, is the oil filter done up tight? And is the cam cover gasket ok? If the cam cover gasket leaks, oil can make it's way right down the front of the engine onto the oil/coolant heat exchanger?

Not sure about your mention of the oil pump - it's inside the sump?
sprint_veloce is offline  
(Post Link) post #3 of 3 Old 23-05-16 Thread Starter
Status: -
AO Member
Join Date: Sep 2015
County: -
Posts: 118
The oil filter is drum tight. There is no leaks from the cam cover, I onlt replaced the gasket when fitting the 2.0 cams. There is no oil on either the side of the head or block. I even checked behind the timing belt cover to see was there any oil and all is dry. The oil is just on the bottom.
What I meant by the oil pump was, can a leak occour between the heat exchanger and the sump. The oil pump housing?
I think it is coming from the heat exchanger where it joins. Is there a gasket inside it and hiw do you remove the heat exchanger.
156Harry is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

leak , oil

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome