Hi Help needed rear crankshaft seal leaking after replacement - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 22-05-16 Thread Starter
Status: -
Join Date: Apr 2016
Location: Southampton
County: Hamepshire
Posts: 3
Hi Help needed rear crankshaft seal leaking after replacement

HI there and hello to all happy Alfa owners
2 weeks ago i have bought myself 147 1.9 jtd Alfa with clutch problem for 350£ in total,
I've removed gearbox and inspected it
after receiving new clutch kit plus flywheel from valeo italy £300 I decided that rear crank seal may need replacing -- I am regretting that now :-( as it was only minor leak
during my installation something had to go wrong because after my first test drive today i have spotted engine oil dripping from gearbox which indicated faulty rear seal

When I was installing new seal all areas where cleaned with brake cleaner and soft rag
silicone rtv added only to the bottom of the seal holder - maybe I should put it around seal holder as well????
after I sliced new seal in place plastic inner ring was removed
in cross pattern manner new seal has been bolted in and torqed to around 15 nm

I am starting removing gearbox again after work tomorrow and possibly I will be able to see where the oil is leaking from- outer seal holder or shaft and seal itself - will kip u updated

It was my first time when I was replacig rear seal and I didn't expect that to go wrong really
If any one is having any ideas what wrong have I done please advise
many thx
mikolayy is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

crankshaft , leaking , needed , rear , replacement , seal

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome