147 Coolant questions - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 05-05-16 Thread Starter
Status: -
AO Member
Join Date: Mar 2016
County: -
Posts: 71

Member car:

147 1.6 120CV

147 Coolant questions

The used 147 I got had a stuck thermostat.

The mechanic changed the thermostat, and the coolant. The car had green coolant before the thermostat change (I read in the manual it should be red, but Im in southern Greece, temperatures never go under 0c, so I guess its some cheaper/hotter alternative)).

The mechanic put green coolant again (no idea about the brand/type), did all the bleeding, rechecking etc, and handed me the car with the coolant exactly at MAX when cold. But he told me to watch it cold over the next few days, and that probably It would drop since there might be trapped air. He told me that after it settled on a level, to bring it back so he could add a little more and bring it to the MAX again.

Indeed, over a week it dropped exactly over MIN, and seems to have stayed there. I'm going back on Monday to fill it up like we discussed, but I wanted to verify if using the green coolant, and this level drop over the first few days is normal.
kourampies is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Apr 2008
Location: New Zealand
County: -
Posts: 2,240
Green coolant is just standard stuff (the red coolant is long life) and will be fine. If you top it back to max and it stays there then the car is fine. If it keeps dropping then there's an issue and it needs to go back to your mech.
sprint_veloce is offline  
Status: -
AO Silver Member
scottyf's Avatar
Join Date: Jun 2012
Location: United Kingdom
County: West Midlands
Posts: 5,173
Images: 26

Member car:

Alfa 166

No point in using the 5 year stuff on a TS engine as you should change the Cambelt and water pump every three years. Well good practice to anyway...
scottyf is offline  
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,994
Without knowing what coolant he used it is impossible to be 100% sure purely based on colour.

There isn't a set colour standard for coolants.

As for the level dropping slightly as the trapped air works its way out, that is fine.
You may find it drops when you open the coolant cap when cold as the level in there can be held artificially high.
David C is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , coolant , questions

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome