Radio Problem 147 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 30-11-07 Thread Starter
Status: -
Join Date: Nov 2007
Posts: 4
Radio Problem 147

Hi there,
I am trying to remove the radio in my Alfa 147,so i bought some cheap removal prongs and thats where the problems started.
They where so badly made that they would not fit into the holes so i filled them down a little,a little to much i think... so now i can't get the radio to release.

If anyone has a close up photo of the prongs that would be great so that i can reshape the ends.
Or any advice would be very help full.
alfanero is offline  
Sponsored Links
Status: One foot in, one foot out!
AO Platinum Member
zulu ferret's Avatar
Join Date: Oct 2006
Location: wgc
County: herts
Posts: 42,255
Images: 2
Re: Radio Problem 147

Gazza, Marko, and some of the others may help, when they are on line.:
zulu ferret is offline  
Status: -
AO Member
Join Date: Apr 2007
Location: chesterfield
Posts: 26
Re: Radio Problem 147

buy a cheap set of thin long screwdriver set from the pound shop, put 1 in each hole then just pull the sterio out!
ASHYMCFC is offline  
Status: bought a 75 3.0
AO Silver Member
155 Lounge Winner 09
shiny_car's Avatar
Join Date: Dec 2006
Location: Australia
County: Victoria
Posts: 7,669
Images: 39

Member car:

GT . 155 . 75

Re: Radio Problem 147

yeah, persevere. as above, screwdrivers have worked for me, but also cut up a wire coathanger. can be a bit fiddly, but you'll get there.

shiny_car is offline  
Status: -
Join Date: Oct 2007
Location: United Kingdom
County: Warwickshire
Posts: 9

Member car:

Alfa 147 2.0TS

Re: Radio Problem 147

I bought these from ebay and they worked a treat (there's a close up picture too so you can look at them)

RADIO REMOVAL KEYS FOR ROVER PHILIPS BLAUPUNKT Free P&P on eBay, also, Other In-Car Ents GPS, In-Car Entertainment GPS, Cars, Parts Vehicles (end time 30-Oct-07 19:10:19 GMT)
knocker01 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , problem , radio

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome