MAF Numbers - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 12-04-16 Thread Starter
Status: Alfa infected
AO Gold Member
purple145's Avatar
Join Date: Oct 2004
Location: United Kingdom
County: West Midlands
Posts: 7,026
MAF Numbers

Hi gents

GT JTD 06 125k miles.

I had flatspots at around 1500-2500rpm, classic MAF symptoms, so it was duly replaced with a genuine Alfa MAF from Jamie Porter along with the hose between it and the turbo. I was getting codes on EcuScan of MAF air quantity and quality. The old MAF was also a bit oily, surprising given it is straight after the air filter.

The new MAF restored a few horses and the flatspot had all but disappeared, however I am now getting the air quantity code repeatedly flag up, typically at idle. It seems more air than is desired is going through the MAF, 500 somethings (can't recall the units ATM) is the measurement and 300 is what the engine is demanding, the graph for the MAF also looks a bit spikey. The flatspots seems a bit intermittant, sometimes linear from low revs, other times it seems to get bogged down then flies as the turbo kicks in.

The accompanying text suggests air leaks, but I have new MAF to turbo hose, silicone top and bottom pipes all done up tightly.

Do I start pulling the car apart or is the MAF likely to be faulty?

purple145 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

maf , numbers

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome