Alfa Romeo 156 indicators - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 26-11-07 Thread Starter
Status: -
Join Date: Sep 2007
Posts: 3
Hmmm Alfa Romeo 156 indicators

This may seem like a stupid question, but I have an intermittent problem with the indicators on my 1998 Alfa 156 (2.5V6), every now and again they flash really slowly and I can't find any explanation in the manual.

Any advice would be great.
johneb68 is offline  
Sponsored Links
Status: -
AO Member
Join Date: Aug 2007
Posts: 69

Member car:

Alfa 156 2.0 TS

Re: Alfa Romeo 156 indicators

I don't know if this is any help at all but I used to have an MGB GT and the more lights/radio/any other electrics you had on the slower the indicator flashed. I replaced the alternator and the battery I think, that fixed it!

Last edited by Timmyk; 26-11-07 at 14:42.
Timmyk is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , alfa , indicators , romeo

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome