Error P0505 solution - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 01-04-16 Thread Starter
Status: -
AO Member
Join Date: Apr 2012
Location: New Zealand
County: Auckland
Posts: 128
Error P0505 solution

I bought a 2.0 TS 147 with a blown engine, and popped another engine in with little drama.

However, error code P0505 idle control popped up regularly and sure enough, it didn't idle steadily.
Lately P1173 and P1176 (mixture lean) started popping up as well.

I found that the red 50mm O ring between the throttle body and plastic inlet plenum had done a Lord Lucan and just vanished! That's where the air was leaking in!

As I had bought the replacement engine without the throttle body I guess it had been lost before I got it, but inexperience meant I didn't spot it absent at the time. I've since done a 1.6 - 2.0 transplant (which have different plastic plenums) and so noticed it immediately when investigating the fault today.
Heavend is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

error , p0505 , solution

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome