Replacing generator - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 01-04-16 Thread Starter
Status: -
AO Silver Member
Join Date: Aug 2001
Location: Denmark
County: North Sealand-
Posts: 1,249
Question Replacing generator

Hi all - does someone have a guide to replace a generator on a 156 2,0 TS year 2000.
A friend of mine have a very loud clatter sound like when the variator is dead, but the clatter doesn't disappear in the usual 10-20 seconds. He has an idea that it's the generator. I've told him to remove the multi belt and start the engine. If the clatter is gone it's either the generator, servo pump or a/c pump, isn't it?
Erik Loye is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Nov 2013
Location: United Kingdom
County: Gwynedd
Posts: 1,147
Seems like a reasonable place to start investigation. If it runs quiet with the aux off then you've narrowed the fault down to all the pulleys and components on the aux.
dgmayhead is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

generator , replacing

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome