2litre twin running rough - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 28-03-16 Thread Starter
Status: Workshop Controller
AO Silver Member
Mito_No3's Avatar
Join Date: Aug 2009
Location: United Kingdom
County: Stirling
Posts: 3,078
Images: 12
2litre twin running rough

Got a friend with a 147 with a 2lite twin spark, Personally can't get to see him for a week or so. He had rough idle and running but seems to clear after about 2500 revs, he has changed both lambdas and spark plugs and I think coil packs as well but will need to check. Fault codes he got retrieved was for lambda faults.

Help and suggestions appreciated for things he can try before I see him.
Mito_No3 is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,996
First thought is: Variator.
David C is online now  
Status: Tin worm attack ... ARGHH!
AO Gold Member
gazza82's Avatar
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 8,290
Images: 12
He did fit Bosch lambdas didn'nt he? If not that will cause errors. I has an NTK one once and it was a pita.

Codes kept showing up and this probably was throwing fueling out.
gazza82 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

2litre , rough , running , twin

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome