Alfa 156 rear O/S electric window not working - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 22-03-16 Thread Starter
Status: Thinking Giulietta QV...
AO Silver Member
Unkle Munkle's Avatar
Join Date: Mar 2003
Location: United Kingdom
County: -
Posts: 1,476
Alfa 156 rear O/S electric window not working

How hard is it to change the rear electric window assembly in the rear door of a 156?

It's literally the only thing that doesn't work properly on the car after fixing/replacing/resolving a couple of other minor issues. I'm so fussy that I like everything to look and work perfectly!

Getting the door panel off isn't a problem. I've replaced one of the rear door handles already.

There is connection to the window as it drops about an inch and that's it. It then takes ages and much fiddling of the switch to get the poxy thing to close. It's not urgent, just annoying!

I see you can buy the whole window assembly off Ebay fairly cheaply...

Rockin' all over the road!
Unkle Munkle is offline  
Sponsored Links
Status: 159 2.4 20007 plate 19,500 DPF/EGR by Adie (AHM)
AO Silver Member
Join Date: May 2009
Location: United Kingdom
County: Wiltshire
Posts: 2,267
Images: 16
kandlbarrett is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , alfa , electric , o or s , rear , window , working

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome