Alfa 156 20v SW Veloce suspension set up - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 15-03-16 Thread Starter
Status: -
Dewhurst88's Avatar
Join Date: Oct 2015
Location: Northwest
County: UK-
Posts: 1
Images: 2
Alfa 156 20v SW Veloce suspension set up


I am new to the Alfa world (last 6 months) and bought a 156 SW 20v jtd...It came with Koni FSD shocks and Ebiach Pro Springs. According to the paper work they are only a couple of years old. The car has GT Multispokes with 225/45/17 tyres. I suffered a blow out due to the tyre catching on the upper suspension arm. Is the car too low, or is there a problem with bushes or faulty control arms? Both front tyres are catching and the rears very really catch unless the car is fully laden. I have been scouring the forum this week and it seems that you can fit 225/45/17s (and 7.5 wheels) with this suspension setup without any issues. Any help would be greatly appreciated.

Dewhurst88 is offline  
Sponsored Links
Status: -
AO Member
buzz11's Avatar
Join Date: Mar 2016
Location: Switzerland
County: Switzerland
Posts: 14
From a technical point of a view it is not really likely that tyre is catching upper suspension arm as arm moves all together with a wheel. It is more likely that is catching a fender as 225/45/17 was never a standard 156 dimension. All depends on rims ET also.
buzz11 is offline  
Status: Busy busy busy!
Club Member
Membro Premio
Pud237's Avatar
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 41,620
Is the tyre catching the hub carrier? It can't be touching the upper arm... Maybe a photo would help us help you?
Pud237 is offline  
Status: -
AO Silver Member
Join Date: Nov 2013
Location: United Kingdom
County: Gwynedd
Posts: 1,147
I have pro springs and 17s with standard shocks and no problems. Your 5 pot is a little heavier and I run 215s not 225s. Could this be the issue?
dgmayhead is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , 20v , alfa , set , suspension , veloce

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome