147 Suspension: What on earth is this?! - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: Running on fumes
AO Member
rathkennades's Avatar
Join Date: Feb 2007
Location: Dublin, Ireland
Posts: 187

Member car:

MiTo Cloverleaf

Re: 147 Suspension: What on earth is this?!

Originally Posted by sirocco View Post
Come to think about it, I painted my calipers right before my last service and I know for certain that wire wasn't there....
The only people who have touched my brakes since was the same dealer I just took it to, so perhaps they are just trying to fob me off onto this story (given my technical ineptitude) as an excuse for their prior negligence......... Just speculation of course.
And I was surprised when they didn't charge me anything for this..... Man I'm slow at times.
Hey sirocco, don't be too hard on yourself! At least they didn't charge you a fortune by saying they had to replace all of the brake wear indicators!
rathkennades is offline  
Sponsored Links

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , earth , suspension

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome