Alfa 156 SW speaker questions - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 12-03-16 Thread Starter
Status: -
AO Member
Join Date: Oct 2015
Location: Kilbirnie
County: North Ayrshire
Posts: 19
Hmmm Alfa 156 SW speaker questions

Hi all,

with my love-hate-relationship (soooo much put into it an still double to come) I have a quite funny question.

The rear speakers (OEM crap) were effed and my scrappy has a 156 pre-facelift with a complete Bose system. Unfort it is a Sedan and not an Estate. So got the front and rear speakers including the tweeters for (muahahaha) 30.

When installing all 6 speakers the system is dead. Not a single sound. When installing the OEM front speakers again the system is mind blowing. I have a JVC (ooold CD radio with Ipod converter) installed which can either put out 30 or 50 Watts. Because the old rears were done I have limited it to 30 Watts. Trying to find out if I need more or different stuff this forum is clear that you need the amp as well.

Now the question: how much does the amp put out to drive the speakers (I don't need the subwoofer). And why does it work with 2 and not 4 main speakers. Would it work when un-limiting my radio as it then has 50 Watts.

Ta Axel
Aggel321 is offline  
Sponsored Links
(Post Link) post #2 of 2 Old 13-03-16 Thread Starter
Status: -
AO Member
Join Date: Oct 2015
Location: Kilbirnie
County: North Ayrshire
Posts: 19

Ok here goes.

IF you don't want to install the subwoofer and only want to replace the OEM speakers (like I did) then yessssss you can install the Bose speakers for the main ones.

As it says on the back of them they are 2 Ohms HOWEVER this is only the case if the tweeter is connected. Because they are parallel this halfs the original 4 Ohms of the two (it helps to have an RT technician in the family). My brother advised to get them in line so cut the BW cable and the B and solder them together. This in turn renders them useless as the power is then sent through the tweeter and broad spectrum at the same time and they sound sh... So what did wee ******* dae: disconnect the BW cable from the tweeter directly and they regain 4 Ohms and work a treat. Plus you still use the original front door tweeters.

IF you want the subwoofer as well please see the other posts as it will be impossible w/out the whole shebang.

Aggel321 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , alfa , questions , speaker

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome