Cambelt broke on gt 1.9jtd 16v - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 06-03-16 Thread Starter
Status: -
AO Member
Join Date: Mar 2016
County: -
Posts: 13
Cambelt broke on gt 1.9jtd 16v

Hello guys,

I'm new here, I'm from Belgium and I drive a GT. As explained in the title my cambelt broke. I removed the cam carrier and all the distribution parts. Everything was in good order except from the belt obvisously and 4 of the 16 rockers.

I would love to have some advice from you guys!

Is it normal that you can plug these rockers off? They seem very loose en unstable??

Should I take of the head aswell to check for bent valves, or is this highly unlikely?

Thanks in advance guys!
Comoreevo is offline  
Sponsored Links
Status: Blue, Cosmos Blue
AO Silver Member
Chris155's Avatar
Join Date: Jan 2014
Location: United Kingdom
County: Cheshire
Posts: 2,157
I don't understand your first question, but in answer to your 2nd, yes, it is unlikely that the valves will be bent. Replace the rockers and cross your fingers.
Chris155 is offline  
Status: -
AO Silver Member
JON156VELOCE's Avatar
Join Date: Jun 2011
Location: United Kingdom
County: Cardiff
Posts: 2,027
As Chris said if all the valves look to be closed properly with the cam carrier off then there is no need to take the head off but I would change all 16 rockers, the broken ones will be obvious but you dont know if any of them have been slightly bent and will break in the future.
JON156VELOCE is offline  
Status: Clattery when cold
AO Member
halftone's Avatar
Join Date: Feb 2012
Location: United Kingdom
County: Greater London
Posts: 849

Member car:

147 Sport Q2

A compression test will show valve damage or not.
halftone is offline  
(Post Link) post #5 of 5 Old 07-03-16 Thread Starter
Status: -
AO Member
Join Date: Mar 2016
County: -
Posts: 13
Thanks for the replies! I think the best option is indeed to check the compression!
Comoreevo is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

16v , 19jtd , broke , cambelt

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome