Another oil question - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 29-02-16 Thread Starter
Status: -
AO Member
gtearl's Avatar
Join Date: Jan 2016
County: -
Posts: 80
Another oil question

Only had my gt jts a month probably done about 500 miles and I've already put a litre of oil in it. Being as im not sure when oil n filter was last changed if they used 10w40 instead of the 10w60 could that explain the high oil usage when I got the car I had to add 1/2 a litre to get it on the gauge . So basically is this normal or do I have to do an oil change and go from there ?
gtearl is offline  
Sponsored Links
Status: now a diesel head..
AO Silver Member
Join Date: Sep 2014
Location: United Kingdom
County: Surrey
Posts: 1,499
Its on the high side definitely...

I would change oil and filter and gauge it from there.

I had a jts GT before my 1.9 bkackline and went through a litte of 10/60 every thousand miles or so but that in 500 is a concern.

Did find the annoying flat dipstick difficult to read sometimes and if often took me a couple of goes to get a clear reading.

So it could just be a combination of lowish oil to begin with and ab ambiguous dipstick reading.

Good luck,hope it settles down.
joeymannero is online now  
Status: -
AO Silver Member
Join Date: Apr 2008
Location: New Zealand
County: -
Posts: 2,240
Like Joey says, firstly change the oil and filter, use 10W60. Generally direct injection engines tend to dilute/contaminate the engine oil with petrol so you want to change the oil regularly, I do my JTS every 10,000km (6k miles) and it's been great.
sprint_veloce is offline  
Status: Busy busy busy!
Club Member
Membro Premio
Pud237's Avatar
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 41,623
Originally Posted by joeymannero View Post
So it could just be a combination of lowish oil to begin with and ab ambiguous dipstick reading.
This is a good point. I would do an oil & filter change and go from there. Oil that is old and broken down will burn faster.
Pud237 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

oil , question

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome