147 JTDM Outside Temperature Display - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 28-02-16 Thread Starter
Status: -
AO Member
Join Date: Mar 2008
Location: United Kingdom
County: Shropshire
Posts: 14
147 JTDM Outside Temperature Display

The outside temperature display on my 147 JTDM was constantly reading anything between -14 and -35, i have changed the sensor in the wing mirror and now it shows the opposite, anything from +25 to +43. Connecting multiecuscan shows up fault code B1973 Climate Control Compressor, saying there is no signal.

Any ideas please?
Jamesh7216 is offline  
Sponsored Links
Status: Thinking about giulia veloce
Club Member
Membro Premio
jwq's Avatar
Club Member Number: 857
Join Date: Jan 2005
Location: The Netherlands
County: Zuid Holland
Posts: 4,104
Images: 16
i'd check the connections from the temp.sensor to the controller box in the drivers door, and the round connector in the drivers doorsil. Sometimes the pins are corroded, and unplugging/plugging already helps
jwq is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , display , jtdm , temperature

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome