AirBag Failure - "Passenger Airbag OFF Lamp" - Alfa Romeo Forum
You are currently unregistered, register for more features.    
 
Thread Tools
(Post Link) post #1 of 5 Old 24-02-16 Thread Starter
Status: -
AO Member
 
Join Date: Nov 2010
Posts: 18

Member car:

147 2L selespeed

AirBag Failure - "Passenger Airbag OFF Lamp"

Hi guys,
I have this error and cant solve it ,
tried to clean contacts and replace on/off passenger airbag switch with used 2nd hand
and after reset it was clean for 1 week and then the airbag light showed up again

i wish someone can help me with this one,

Elad.
Attached Images
File Type: png airbag.png (126.5 KB, 14 views)
el@d147 is offline  
Sponsored Links
Advertisement
 
Status: -
AO Member
 
Join Date: Dec 2014
County: -
Posts: 106

Member car:

156

Seems the fault is the indicator light in the speedo rather than the passenger airbag switch?
gwinter is offline  
(Post Link) post #3 of 5 Old 24-02-16 Thread Starter
Status: -
AO Member
 
Join Date: Nov 2010
Posts: 18

Member car:

147 2L selespeed

thanks for answer m8,

what do you mean?
how could it be faulty?

i forgot to tell that the yellow light come first and than the red light.
sometimes after those lights come on the yellow become off and i have only the red one and on and on...
el@d147 is offline  
 
(Post Link) post #4 of 5 Old 20-07-16 Thread Starter
Status: -
AO Member
 
Join Date: Nov 2010
Posts: 18

Member car:

147 2L selespeed

hi,

i didnt solve it yet,

anybody can help?
el@d147 is offline  
Status: Spider put in winter hibernation
Club Member
Membro Medio
 
Henrik_45's Avatar
 
Join Date: Jan 2013
Location: Denmark
County: Aalborg
Posts: 505
Garage
Do the passenger airbag OFF lamp come on?
If not the LED might be broken.

Have you tried to use the passenger airbag switch to see if it has a poor connection.
I assume you have LHD cars in Israel so the switch should be in the passenger side.
Use the ingintion key to switch the airbag On and Off
Henrik_45 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

Tags
airbag , failure , passenger airbag off lamp

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome