alfa 156 1.8 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 22-02-16 Thread Starter
Status: -
Join Date: Feb 2016
County: -
Posts: 2
alfa 156 1.8

Hi everyone, need some help pse.
I have a 1.8 ts old r reg 156
Got an issue with the rattle, however not sure if its variator or lifters.
On cold start engine smooth quiet.
When its warm tickover up to 800 rev the dreaded rattle.
Can variator be noisy only wen engine is warm, or can tappets rattle also?
Any advice please?

Last edited by bryanatyaxley; 22-02-16 at 16:40. Reason: misspelt
bryanatyaxley is offline  
Sponsored Links
Status: -
AO Silver Member
scottyf's Avatar
Join Date: Jun 2012
Location: United Kingdom
County: West Midlands
Posts: 5,173
Images: 26

Member car:

Alfa 166

Check your oil isn't low.
If there isn't enough oil it won't get pumped to the variator.
scottyf is offline  
(Post Link) post #3 of 4 Old 22-02-16 Thread Starter
Status: -
Join Date: Feb 2016
County: -
Posts: 2
Thanks, oil is fine, I may go for the lifter option.
Many thsnks
bryanatyaxley is offline  
Status: - Update
Posts: n/a
I was sceptical about lifter treatments working on sticky lifters, but my car has been vastly improved by using one. Mine is a diesel but I see no reason why you might not have similar results with the 1.8 TS. Worth a try.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , alfa

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome