jtd owners help please - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 11-11-07 Thread Starter
Status: -
AO Member
Vespasian's Avatar
Join Date: Jun 2006
Location: United Kingdom
County: Norfolk
Posts: 528
Not Happy jtd owners help please

This one is still confusing me (not hard to do). The car is a 2.4 jtd 136bhp version, it pulls hard fom low revs, then at around 2500 rpm, the car starts to pulsate the power with it coming on and off until it goes past 3250 rpm, then the injector light comes on and when you change gear, the car goes in safe mode until you release the throttle and all is fine again until you rise up the rev range.

To make things more confusing, it only seems to pulsate when you rev the car hard (not thrashing)

Sometimes the car does not pulsate, but there is a loss of power and the injector light comes on. I know it could be the MAF, but whether that would cause all of that and the safe mode driving, not so sure.

The car does not emit any smoke from the pipe, and the turbo whistle seems ok.
Before alfa take any of my hard earnt pennies, any one got any ideas
Vespasian is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

jtd , owners

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome