Battery fuses - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 08-02-16 Thread Starter
Status: -
AO Member
GUE57's Avatar
Join Date: Mar 2015
Location: Australia
County: Western Australia
Posts: 11

Member car:

Ducati Diavel

Battery fuses

Hey guys,

In my search to find why there is no power to my stereo I found something unrelated. On my battery fuse box I do not have the little reference lid, and in my standard fuses there seems to be one missing.

All the pictures I've found have been diesels, Does anyone have a picture of the fuse reference for a 2.5L V6 (Q-System if that makes a difference). It worries me because with the diesels, not only was there a fuse there but some of the other fuses were different amounts.
Attached Images
File Type: jpg IMAG1351.jpg (60.0 KB, 12 views)
GUE57 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

battery , fuses

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome