147 Oil Pressure - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 07-02-16 Thread Starter
Status: -
AO Member
TheRyanSpain's Avatar
Join Date: Jan 2016
Location: Ireland
Posts: 13
147 Oil Pressure

My 147 has recently been flagging low oil pressure on the dash. I checked oil level and all is good.

I diagnosed it using Torque and returned error code P1682 which from what I can see is a manufacturer defined code. From that I found its a Metering Oil pump malfunction.

There's no symptoms while driving, no noise, lack of performance only that when I pulled into my drive after and hour long drive the Oil pressure error was on the dash.

I just want to know is there anything I can do before taking it to a garage to possibly have the cost of labour involved in replacing the pump.

Appreciate any advice.
TheRyanSpain is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , oil , pressure

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome