rear boot and power windows not working Alfa 147 GTA - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 18-01-16 Thread Starter
Status: -
Join Date: Apr 2007
Posts: 4

Member car:

GTV + 156

rear boot and power windows not working Alfa 147 GTA

Hi all,
hoping someone can assist as my mechanic is away till the end of the month.
Suddenly both my boot and power windows will not function. Boot won't open with either internal dash push switch or key. Windows won't function at all - switches on doors are illuminated.

any assistance will greatly be appreciated
doss is offline  
Sponsored Links
Status: +o-V-o+
AO Silver Member
Giorget2's Avatar
Join Date: Jan 2012
Location: South Africa
County: Gauteng
Posts: 3,119
First thing to check with any electrical gremlins on the 147 is always the battery. Make sure it's in good condition - possibly swop for a definitely functioning battery and test that before you fiddle around with anything else.

Unless these are common symptoms of another problem that someone else can diagnose.
Giorget2 is online now  
Status: Thinking about giulia veloce
Club Member
Membro Premio
jwq's Avatar
Club Member Number: 857
Join Date: Jan 2005
Location: The Netherlands
County: Zuid Holland
Posts: 4,105
Images: 16
They are all controlled by the same unit, the controller in the drivers door.
I would first check the fuses, that would be the most logical fault.....
(F47/20 Amp, F39/15Amp, .. ? )

Last edited by jwq; 18-01-16 at 07:59.
jwq is online now  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , alfa , boot , gta , power , rear , windows , working

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome