Alfa GT p0651 error code - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 17-01-16 Thread Starter
Status: -
Join Date: Nov 2015
County: -
Posts: 1
Alfa GT p0651 error code

Hello everybody.
I'm new here and immediately turn to you with a problem
Begin with a little background for the car.Car arrived from Italy without a drop of oil and water in it.
It appears broken turbine and leaky water radiator.
Disassembled the turbine and head.I change everything, a new cartridge,head gasket with erasers and matching valves.New timing belt, water pump and pulleys, termostat.Clean ERG and intake manifold
The problem is that when you start the engine idling holds 1500 rpm.Rpm fall only if the brake continuous or stop off clipper.
Error which gives the car is p0651 Sensor power supply 2.
Incidentally we have seen is that ERG does not work sit your 0% but no matter what rpm without error in it .
The car is 2004 AlfaRomeo Gt 1.9 jtd
I would be grateful to anyone to solve the problem
REDPOWER is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

alfa , code , error , p0651

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome