Alfa 147 Won't crank` - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 15-01-16 Thread Starter
Status: -
Join Date: Nov 2015
County: -
Posts: 4
Alfa 147 Won't crank`


Having trouble with my 147 Selespeed, i purchased the car not going ( won't crank and the neutral light is flashing), i found some blown fuses and a few bad connections here and there but still no luck, i can get the car to run by bridging the starter motor but still won't select gears and the neutral light remains flashing. There are no trouble codes in the selespeed system and i have run a calibration with a Snap on scan tool with no luck, i can also individually check the clutch , servos etc and all seem to work fine, the only thing that appears on the scan tool when i go through the data is i can see 'engine start up' and next to that it says 'not allowed', i know the key is fine and there are no trouble codes in any of the systems, and the brake light switch is new. My next step is to find a good auto electrician but just thought i would put it out there first, thanks
stic man is offline  
Sponsored Links
Status: 159 2.4 20007 plate 19,500 DPF/EGR by Adie (AHM)
AO Silver Member
Join Date: May 2009
Location: United Kingdom
County: Wiltshire
Posts: 2,267
Images: 16
I'm surprised that a scan tool will do everything needed for a selespeed and would only consider MES downloaded and paid for but I might be wrong on that.

I am not sure what the free version will do with selespeed but perhaps consider trying that first. My experience is that V2.6 of FES (predecessor or MES) was one of the least locked of the free versions but again I don't have any experience with the selespeed.
kandlbarrett is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , alfa , crank`

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome