Sticky Pedals-common problem? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 30-10-07 Thread Starter
Status: Cultural Attache
AO Silver Member
David Jarrett's Avatar
Join Date: Mar 2006
Location: United Kingdom
County: Kent
Posts: 2,899
Sticky Pedals-common problem?

I seem to have aquired a Friday afternoon 159 2.4 JTD.

Both the clutch and brake pedals are lazy to return. I have tried WD40around the pedal box but access (for can and feet!) is very limited. Anyone else come across this... I assume the dealer can take it apart and lubricate the mechanism?

Then there is the instrument rheostat which won':t dim to the lowest setting, reverts to what it chooses and on occasions randomly brightens and darkens at will.

I am trying to convince myself that this is a nicer car than my 156 Sportwagon....
David Jarrett is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

pedalscommon , problem , sticky

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome