Bosch spark plugs in TS- rubbish - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 12-12-15 Thread Starter
Status: Hopefull!
AO Member
Join Date: Feb 2014
Location: Ireland
County: Tipperary
Posts: 63

Member car:

'06 156 1.6TS

Bosch spark plugs in TS- rubbish

Bought a '06 1.6 156 lately.
Got it running on LPG and when put under a little bit of pressure, the dreaded Engine Management Control Error kept coming up. On petrol the error didn't show.
Had feared lots of things but decided first to go with plugs.
It has 144k kilometres on the clock. The previous owner said that they were changed a 125k km - so they shouldn't be that bad!
Two broke taking them out and four other were obviously cracked - hopefully the image uploaded.
Have eight new original plugs fitted and it runs much better.

Had also thought that the clutch was on the way out as when cold it juddered really badly. Turns out it was just the plugs!
Attached Images
File Type: jpg 2015-12-12 16.36.05.jpg (174.6 KB, 19 views)
Dr. Dave is offline  
Sponsored Links
Status: -
AO Silver Member
alfizta's Avatar
Join Date: Jun 2008
Location: Portugal
County: -
Posts: 2,631
Images: 10
bad, bad, bad bosch!
alfizta is offline  
Status: Alfa infected
AO Gold Member
purple145's Avatar
Join Date: Oct 2004
Location: United Kingdom
County: West Midlands
Posts: 7,026
thats German engineering for you.......
purple145 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

bosch , plugs , rubbish , spark

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome