156 coolant loss - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 22-10-07 Thread Starter
Status: -
AO Member
Join Date: Mar 2004
Posts: 60
156 coolant loss

My 2.5 156 never over heats but it does have a strange water leak. Every week i top up my expansion leak to the max mark, for the next day or so whenever i park my car i return to find water on the floor. The water seems to find its own level then dosent leak again until after i have topped it up again. Does anyone have an y ideas how or why this happens, or if its anthing to worry about.
palaceray is offline  
Sponsored Links
Status: Busy busy busy!
Club Member
Membro Premio
Pud237's Avatar
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 41,620
Re: 156 coolant loss

Might it be the lid on the expansion tank?
Pud237 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , coolant , loss

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome