147 selespeed ticking noise when idling - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 21-10-07 Thread Starter
Status: -
AO Member
whild147's Avatar
Join Date: Jul 2007
Location: United Kingdom
County: West Midlands
Posts: 28
147 selespeed ticking noise when idling

I've got an annoying noise coming from the engine of my 147 when it's just sitting ticking over, sounds very taxi ish. I've recently had the cam belt, tensionors and variator done. I've also had to have front cats changed due to a previous rattle. The sound seems to die off when i put it in gear so i'm wandering if it's the clutch or something like!!!
I only picked it up from a service yesterday and the mechanic had checked for the rattle and seemed to solve it but after 20 minutes driving it seems to be back. I'm booking it back in next week but was wandering if someone knew what it could be.
whild147 is offline  
Sponsored Links
Status: -
AO Member
Join Date: Nov 2005
Location: Gloucester UK
Posts: 233
Images: 2

Member car:

147 Selespeed

Re: 147 selespeed ticking noise when idling

I read somewhere on here that this could be the sound of the injectors and is normal. Not sure though - may be lead for you.

Dai Alfa is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , idling , noise , selespeed , ticking

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome