MCSF light on - with the following codes... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
  • 1 Post By joeymannero
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 02-12-15 Thread Starter
Status: -
AO Member
eludlow's Avatar
Join Date: Sep 2010
Location: United Kingdom
County: Kent
Posts: 99
MCSF light on - with the following codes...

Parking my 1.8ts GT at home yesterday my MCSF light came on - ugh! No feeling of rough running or anything untoward. Switching the ignition off and on again and it remained but the engine sounded absolutely fine, so today my ever helpful mechanic popped round with the diags box and connected it up:

o2 sensor failure 2 signal before CAT
ignition failure (generic)
ignition failure cylinder 3
ignition failure cylinder 4

He reckons the o2 failure is a red herring triggered by lack of ignition, but that it's very unusual to get ignition failures on 2 and 3 at the exact same moment - seems odd two coils would go at the same time, and spark plug failure (they're less than 10k miles anyway) on a TS seems unlikely. We wondered whether a tiny bit of guff or water in the fuel possibly. For now the codes have been cleared and in 5-10 miles driving this PM they didn't re-appear and the car felt totally fine and smooth, which to me would indicate crud in the fuel.

So plan is do nothing UNLESS the MCFS light comes back on in the next few weeks, in which case change the ignition coils on cylinders 2&3.

What do others reckon?

eludlow is offline  
Sponsored Links
Status: now a diesel head..
AO Silver Member
Join Date: Sep 2014
Location: United Kingdom
County: Surrey
Posts: 1,492
if they come on again...


I have literally lost count of the number of times electrical gremlins were due to a battery on the way out, MCSF light/engine rev cycling/window problems all sorts of weirdness.

the main reason I say this is because as you said ignition failure on 3 and 4 at the same time is a bit suss...that and the O2 sensor.

hope that helps.

I would start there before doing anything else.
dgmayhead likes this.
joeymannero is offline  
(Post Link) post #3 of 3 Old 03-12-15 Thread Starter
Status: -
AO Member
eludlow's Avatar
Join Date: Sep 2010
Location: United Kingdom
County: Kent
Posts: 99
Thanks joeymannero - if it comes back on will give that a go. Would be surprised though - the battery in the car is an approx 2.5 year old Varta - would be surprised if it's going yet...

Fingers crossed it won't come back on, though...
eludlow is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

codes , light , mcsf

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome