Digital Display Issues On 156 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 18-10-07 Thread Starter
Status: -
pmptrading's Avatar
Join Date: Sep 2006
Posts: 114
Images: 7

Member car:

Alfa Romeo 156

Digital Display Issues On 156

I have a 156 Sillyspeed..... the LED display which shows which gear the sellyspeed is in sometimes is corrupted.... ie the numbers are disfigured.... especially the N or R

I have no idea why..... hope it is not $$$$ to fix.
pmptrading is offline  
Sponsored Links
Status: -
AO Member
evilscotsman's Avatar
Join Date: Sep 2007
Location: Fife, Scotland
Posts: 441
Images: 1

Member car:

2003 156 JTD 1.9

Re: Digital Display Issues On 156

if certain segments of an LCD go wrong, its usually a fault with the connection strip to the LCD display panel itself, called the "zebra" strip.

It would need a replacement display, not a home diy job as its bonded to the PCB.

Best to try and find a complete display from a scrapper, and replace your display unit.
evilscotsman is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , digital , display , issues

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome